Archive for October, 2009

h1

User Alerts on Site Collection causes error

October 9, 2009

So I was trying to manage user alerts that were getting bounced due to ex-employees no longer having valid mailboxes.  I go into the Site Collection and get a wonderfully straight forward and insightful message:

Object reference not set to an instance of an object.   at Microsoft.SharePoint.ApplicationPages.SiteSubsPage.OnLoad(EventArgs e)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Now as with all SharePoint errors I immediately go to Google…and find that there are Hot Fix updates for August 2009

WSS 3.0 http://support.microsoft.com/kb/973410/  

MOSS 2007… http://support.microsoft.com/kb/973409/

Included in the WSS 3.0 Hot Fix is “After you install Office SharePoint Server 2007 Service Pack 2, you receive the following error message when you try to visit the SiteSubs.aspx”.   So apparently my quest to Service Pack my SharePoint server broke something that needs another fix.  I will be running these on my development server and then install on my production box…will report back if the issue is resolved.

UPDATE: New SharePoint Moss 2007 version on development server is 12.0.0.6514  Verified that the User Alerts page now works.  Will be installing on my production server soon.

Advertisements
h1

Welcome to my site…

October 7, 2009

I have been meaning to write a blog for a long time, but never got around to it.  The main goal of this site will be to share my findings about SharePoint 2007 and the daily trials and tribulations I encounter with this product.  It is a blessing and a curse to run a SharePoint environment…I will do my best to share insight and findings that I think are valuable to the hoi polloi!

I have found many solutions to problems that have eluded me in the past using other blogs on the interweb…I hope my findings will prove to be just as valuable to the community at large.